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Telus PSS can integrate with Ocean in two ways:

1) Standard integration via the Ocean eForm (most common)
2) Cloud Connect/Telus API integration (requires paid subscription). Additional steps related to this are shown in

brown.

Description
TELUS PSS SET UP

1 Set Up Ocean Site
☐ Set up Ocean Account and Ocean Site for clinic (if one doesn’t already exist)

o Clinic creates account  at https://ocean.cognisantmd.com/ and creates Ocean site
OR

o DT creates Ocean Site: Click name in Portal (top-right) > My Account > Create New Site and
invites clinic contact from Menu > Admin > Users

☐ Once site is created, all other users to be added through Menu > Admin> Users
[Note: The clinic contact you are working with for the setup should be an admin in Ocean and an admin in
Telus PSS to complete the steps below]

☐ Create encryption key
2 Download and Import Ocean Custom Forms Link to Article/Video

☐ Visit https://www.oceanereferralnetwork.ca/resources/ and click on the following resources to
download them to an easily accessible folder or the desktop of the client’s workstation (these can also be
sent as attachments in an email ahead of time):

1) Ocean Custom Form
2) Ocean Toolbar
3) Ocean eReferral Custom Form
4) Ocean Attachment Exporter
5) Ocean Incomplete eReferral Custom Form (optional, but recommended especially for Senders to

facilitate save-for-later sending flow)
6) Ocean eReferral Appointment Notification Custom Form (optional, but recommended especially

for Receivers to send appointment information from Telus PSS to Ocean)
☐ Import the downloaded forms into Telus PSS

o Login to PS Suite -> Records window -> Settings -> Edit Custom Forms
o From Forms window -> File -> Import Form(s)
o Locate &  select files the downloaded Telus files and click Choose

▪ If forms already exists in Telus PSS you may be prompted to update the form. Select
“Yes, Update Form” to safely overwrite the earlier version of the form.

o Close the Forms window

3 Create Reminder Trigger for Ocean Toolbar Link to Article/Video

https://ocean.cognisantmd.com/
https://support.cognisantmd.com/hc/en-us/articles/115003468791-PS-Suite-Download-Install-the-Ocean-Custom-Form-Toolbar-and-Attachment-Exporter
https://www.oceanereferralnetwork.ca/resources/
https://support.cognisantmd.com/hc/en-us/articles/115003492392-PS-Suite-Create-a-Reminder-Trigger-for-the-Ocean-Toolbar


Ocean-Telus PSS Setup Step-by-Step Checklist (Senders & Receivers)
- August 26, 2021

☐ Open the Edit Reminders window and add a new reminder
o From the Records window -> Settings -> Edit Reminders
o From Edit Reminders window -> Edit -> Add Reminder
o Enter Reminder Name as “Ocean Toolbar”
o Click “Add Line” to prompt the Add Search Criterion window

▪ To have Toolbar show for all users -> select Demographics -> Age <= 200
▪ You can adjust criteria to make toolbar only appear for certain users or patients

o Click the “Show Custom Form or Stamp” radio button, then click the Ocean Toolbar from the
dropdown

o Click Done
o Open a patient chart matching to confirm the toolbar appears under the CPP

4 Configure the Ocean Custom Form Link to Article/Video
[Note: This step requires user to be an Ocean administrator and  have their Ocean username, password,
Ocean site number, and site shared encryption key]
☐ Open a test patient chart
☐ Click Ocean logo on Ocean Toolbar to prompt the Ocean Custom Form

o On the Ocean Custom Form -> Settings
o Enter Ocean username and password

☐ On Ocean Setting dialog box -> click Ocean Site Number -> Enter Ocean site number
☐ On Ocean Custom Form -> Settings -> click “Shared Encryption Key” -> Enter encryption key
☐ On Ocean Custom Form -> click “Close” to remove it from the chart

5 Enable Cloud Connect on Ocean Custom Form (CC only) Link to Article/Video
☐ Open a test patient chart
☐ Click Ocean logo on Ocean Toolbar to prompt the Ocean Custom Form

o On the Ocean Custom Form -> Settings -> Advanced…
o Select or double-click “Ocean/Cloud Connect Activated:N” and click “OK” on the prompt to

change Cloud Connect activation to “Yes”

6 Configure the Ocean Integration Module (CC only) Link to Article/Video

https://support.cognisantmd.com/hc/en-us/articles/115003492592-PS-Suite-Configure-the-Ocean-Custom-Form
https://support.cognisantmd.com/hc/en-us/articles/115002099151-Accuro-Add-User-Friendly-Buttons-to-CDS-Links-
https://support.cognisantmd.com/hc/en-us/articles/115002099151-Accuro-Add-User-Friendly-Buttons-to-CDS-Links-
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[Note: This step requires Telus PS Suite version 5.11 or higher. To find the version number of Telus PS
suite EMR, follow the steps in this support article]
☐  Create a new EMR user named “Ocean Connect”

o From the Telus Dashboard window -> Settings -> Edit Users… -> Enter PSS password
o From Users window -> Edit -> Add New User
o Create an Ocean Connect user with the following details:

▪ First Name: “Ocean”
▪ Surname: “Connect”
▪ Initials: OCNC
▪ Role: “Other Health Professional”
▪ Authority: “User”
▪ Special Privileges: box checked
▪ View Privileges: “All”
▪ Action Privileges “Notes”
▪ Under Accessible Locations, ensure all locations in the drop down have a checkmark

next to them
o Click “Add”

☐  Configure the Ocean Integration Module
o From the Telus Dashboard window -> Settings -> Preferences…-> Enter PSS Password
o From Preference window -> Mobile [Note: this can only be accessed if the clinic has their

mobile Telus API set up]
o From Mobile -> click Integration Management -> click purple “Configure” button

▪ Ensure “Enable Ocean by Cognisant MD” is checked ON
▪ From Select User dropdown, click “Connect, Ocean”
▪ Record EMR Instance ID & EMR Secret (needed for next step)
▪ Click “Save”

6 Set Up Ocean Cloud Connect (CC only) Link to Article/Video

☐  Visit https://cloudconnect.cognisantmd.com/ in a browser, and have the user log- in with their Ocean
User Name and Password

o Click “Integrate with your EMR”
o Enter Shared Encryption Key and click “Save and Continue”
o Select “Telus PS Suite” and click “Next”
o Enter EMR Instance ID and EMR Secret from step 5 above and click “Next”
o From the Edit Settings window:  you can customize configuration options (details in this

support article) but in most cases the default configuration will be sufficient
o Click “Save”

☐  On the main summary screen, view the “Sync Status” to confirm Telus PSS is syncing with Ocean
o If there are errors with the configuration an alert will be displayed on the main summary

screen

☐  Ensure Cloud Connect is activated in Ocean Portal
o Log in to Ocean Portal at https://ocean.cognisantmd.com/
o Click Menu -> Admin -> Site Features

▪ Ensure “Enable Ocean Cloud Connect” is checked ON

https://support.cognisantmd.com/hc/en-us/articles/204437478-PS-Suite-Finding-Your-PS-Suite-Version-Number
https://support.cognisantmd.com/hc/en-us/articles/115003470011-PS-Suite-Configure-the-Ocean-Integration-Module
https://cloudconnect.cognisantmd.com/
https://support.cognisantmd.com/hc/en-us/articles/360012088012
https://support.cognisantmd.com/hc/en-us/articles/360012088012
https://ocean.cognisantmd.com/
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▪ [For Receivers using Cloud Connect] Ensure “Allow accepted eReferrals to create
patients in your EMR” is checked ON

7 Send or Receive a Test Referral
Link to Telus PSS
Sending/Receiving
Workflow Videos

Sending Workflow (repeat for each user to link EMR user account with Ocean user account)
☐  Open a test patient profile
☐  To attach a note from the patient’s chart

o Click checkbox next to the desired note to “Green Bar” it

☐ Click “Refer” on Ocean Toolbar to launch Ocean Healthmap
o On Healthmap ->  ‘Click Here to Link Your Ocean Account’ if needed in the top-right (to

establish single sign on iif Ocean account not yet linked to EMR account)
o Select a receiving listing> Click “Send eReferral” > Verify patient & referrer data is pulled into

form correctly > Verify Attachment appears toward bottom of the referral form
o Complete the eReferral and the following will be added to chart

▪ Referral Form Summary
▪ Ocean eReferral Custom Form
▪ Telus PSS Sticky Note
▪ +/- Green Pending Test/Consult Note

☐  Configure settings on Ocean eReferral Custom Form (support article)
o On Ocean eReferral Custom Form -> Click Settings

▪ Select user who will follow-up with referrals (enter user initials or group (e.g. “secs”))
who will receive the follow-up sticky message

▪ Select the follow up wait period
▪ Set the email to receive referral status updates
▪ Add Pending Test Consult

☐ Additional actions in Telus
o On Ocean eReferral Custom Form -> Click “Open” to view eReferral in Ocean Portal
o On Ocean Toolbar -> Click “View in Ocean” or “__ Outstanding” to view patient dashboard
o On Ocean Toolbar -> Click “Portal” to open Ocean Portal in browser

Receiving Workflow

☐  Click “Accept” on a Referral in Ocean
o [Standard Integration] From Import Window note the Import Code

▪ Search for patient in Telus PSS or create a new stub profile (from PSS Dashboard ->
Patients -> File -> Add Record -> Enter First & Surname -> clik Save)

▪ On Ocean toolbar in patient’s chart -> Click “Import” -> Enter Import Code
o [Cloud Connect Integration] Ocean searches Telus for patient with matching HC

▪ If patient exists, Ocean will update demographics and import referral summary to
chart

▪ If patient does not exist, Ocean will create patient profile and import demographics
and referral summary

o Click “Download” on Import window to download full referral record to scanned documents
folder or another location as per clinic preference

https://www.youtube.com/playlist?list=PL6xOKDHJgV-E-6edXgECon8thKdCeLULy
https://www.youtube.com/playlist?list=PL6xOKDHJgV-E-6edXgECon8thKdCeLULy
https://www.youtube.com/playlist?list=PL6xOKDHJgV-E-6edXgECon8thKdCeLULy
https://support.cognisantmd.com/hc/en-us/articles/115001638631-PS-Suite-Ocean-eReferral-Custom-Form-Settings
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☐ Additional actions in Telus
o From PSS dashboard -> Appointments -> Click an open slot in scheduler ->  search patient

name -> click OK -> open/refresh patient’s chart to see “next visit” displayed in top-right
o From patient’s chart -> View -> Custom Forms (or F2 shortcut) -> search Ocean eReferral

Appointment Notification Form -> Choose this Form -> launches Patient Dashboard in Ocean
-> select referral to see appointment time available to be added in Scheduling pane

Common Troubleshooting

Items recorded in patient’s chart under wrong user/wrong initials [eReferral sender, standard integration]
Issue: Users may report that the items generated by Ocean in the patient chart (referral summaries , pending
tests/consults or eReferral custom forms) are recorded with the wrong user’s initials (see screenshot).

● This usually is discovered some time in the future or  the next time the patient chart is accessed by a user,
rather than right at the time a referral is sent

(Referral was sent by C. DeGroot but another user, JELA, has their initials stamped)

Management: This happens due to some limitations with PSS’ integration with Ocean. Upon sending a referral, it
may take a few seconds  before the items generated by Ocean are added to the patient’s chart. If the sending user
closes the patient’s chart before the items are added, these items are typically added the next time the chart is
opened. At that time, PSS will stamp these items with the initials of whichever user has opened the cart.

● Although this can be distressing for clinics, it’s usually not a major clinical concern, and there are clear audit
trails indicating who sent the referral.

● The simplest strategy is to avoid this issue is to train  PSS sending users to wait for a moment on the
patient’s chart after sending the referral to confirm the note, eReferral custom form +/- pending
test/consult have been added.

● With respect to Pending Tests/Consults, some clinics may choose to deactivate the automatic addition of
the pending test/consult using the eReferral Custom Form settings (see screenshot). They will still have the
option to manually click “Add PSS Pending Test/Consult” from the eReferral custom form after sending the
referral.
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Appointment time from Telus PSS not appearing in Ocean [eReferral Receiver]
Issue: While attempting to send an appointment time from Telus PSS to Ocean for a received referral, the user
launches the Ocean eReferral Appointment Notification form and may be prompted to sign in. When they click on
the patient’s referral on the dashboard, the appointment time from Telus does not appear in the Scheduling pane of
the referral as expected.

Management: Most commonly, this is due to the user not having Single Sign On (SSO) established between their
EMR user account and their Ocean account, which is easy to overlook if the user is not sending referrals.

● To establish SSO, the user should click “Refer” on the Ocean Toolbar to prompt the Healthmap, then click the
message in the top right that says “Hello [EMR Username]. Click here to link your Ocean account”. They will
be prompted to enter their Ocean information to link their Ocean account to their Telus PSS account.

● Once SSO has been achieved, the user can try using the Ocean eReferral Appointment Notification form
again, and the appointment should appear.

● Note: Ocean will not be able to sync appointment details if there is not a valid Health Number associated
with the referral.

CSRF Security Error [eReferral Sender or Receiver]
Issue: User is prompted with this CSRF Security Error message (see screenshot) when clicking either  the “Portal”
button or the “Refer” button from their Ocean Toolbar.

● This error may only be happening to a particular user, or on a particular workstation/browser
● This error may emerge even if the user has been working with Ocean for a while without issue

Management: A CSRF Security error means that the browser could not create a secure cookie, or could not access
that cookie to authorize the login. This can be caused by ad- or script-blocking plugins, but also by the browser itself
if it’s not allowed to set cookies. It can also occur when the page has been opened for an extended period of time
causing the token to expire.

Consider trying the following to fix the error with the site’s permission:
● Ensure the user is using an up-to-date browser. [Instructions for Google Chrome and Firefox]
● Ensure the browser accepts cookies [Instructions for Google Chrome, Firefox]
● Clear your cache and remove all cookies from your browser [Instructions for Google Chrome, Firefox]

○ NOTE: When you delete cookies from your computer, you erase information saved in your browser,
including your account passwords, website preferences, and settings.

● Refresh the page
● You can also try accessing Ocean through an Incognito window in Chrome.
● If these steps do not work, please contact techsupport@thinkresearch.com

Only 1 Pending Test/Consult generated despite 2 or more referrals sent [eReferral Sender]
Issue: When sending two referrals for the same patient on the same day, it appears that sometimes only 1 Pending
Test/Consult is automatically generated in the patient’s chart.

Management: This appears to be a Telus quirk when two referrals are sent for the same patient on the same day.
Sometimes the second pending test/consult fails to enter the chart. There are no specific steps to prevent this quirk,
but a potential strategy is to just manually click to Add PSS Pending Test/Consult using the quick button adjacent to
the eReferral Custom Form.

https://support.cognisantmd.com/hc/en-us/articles/360022567592-PS-Suite-Advanced-Features-for-Sending-Appointment-Notifications-
https://support.google.com/chrome/answer/95414?hl=en&co=GENIE.Platform%3DDesktop
https://support.mozilla.org/en-US/kb/update-firefox-latest-release
https://support.google.com/accounts/answer/61416?hl=en&co=GENIE.Platform%3DDesktop
https://support.mozilla.org/en-US/kb/websites-say-cookies-are-blocked-unblock-them
https://support.google.com/accounts/answer/32050?hl=en&co=GENIE.Platform%3DDesktop
https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox
mailto:techsupport@thinkresearch.com

